Newb conceptual help - zeroing object surface to the xz grid

Cadlet

Member
Please correct me if I'm wrong. Is XZ is the name of plane shown by default as the "floor" grid when you open C3D for the first time? Anyway, whatever that grid is called, if I create a box object, for example, the visible (grid) cuts right through the halfway mark on that box. How do I make one of the parallel faces of the box precisely intersect or align with that plane? In other words, what position properties put the new box on the floor rather than half above and half below it? is this a default that can be set for appropriate objects?
 

uncle808us

Well-known member
If the box is 1x1x1 then if you transpose it up Y to 0.5 half the size of the box then it is on the x/z axis. hope this helps.
Floor.jpg
 

frank beckmann

Well-known member
Another method is to use the Transform panel position property with gadget mode (works with parametric objects as well): select the polygon/plane/surface in gadget mode you want to align to Y=0 and simply type in Position Y=0 - Done.
AlignmentxyPlane.gif

Cheers
Frank
 

Cadlet

Member
Thanks, uncle808us and frank. I think I can make that work. I wish there was an option to make a side's position zero by default. Thanks again.
 

Cadlet

Member
OK, I was wrong, Frank, I don't understand how to use your suggestion. My position Y appears as -0.5, and I'm unable to edit it (it snaps back to -0.5 whenever the cursor leaves the field).
transform tool position Y.jpg
 
  • Like
Reactions: DEO

Cadlet

Member
If the box is 1x1x1 then if you transpose it up Y to 0.5 half the size of the box then it is on the x/z axis. hope this helps.
OK, thanks. So after performing this maneuver, how then can I reinitialize the orientation of the box so that its position Y will permanently be displayed as 0 rather than 0.5?
 

frank beckmann

Well-known member
OK, thanks. So after performing this maneuver, how then can I reinitialize the orientation of the box so that its position Y will permanently be displayed as 0 rather than 0.5?
In this case you need either an editable mesh - then go Tools->Coord System->burn transform or add a transform-modifier and adjust the placement there.

Cheers
Frank
 
Last edited:

Cadlet

Member
You´ll find it under Tools->Coord System="Burn Transform".
Thanks. I forget to look in the Properties area of the window, because I like to remove that in my view sometimes. But I have an imported object, and the transform is out of place a bit. I know I permanently reposition the transform tool for the object accidentally, but I've forgotten how to do it intentionally. Can you refresh my memory, please? Thanks again.
 

frank beckmann

Well-known member
Let´s see - there a more than one way to do it:
Quickest way to get objects center to XYZ=0 is to call Coord-System tool and hit "Center Pivot Point", then "Burn pivot point" and adjust at Polygon object "Position" to XYZ=0,0 - done.
Or if you want a specific point to be at YZX=0 like a the ground plane of a house for instance go in "Pivot-mode" - snapping to component at the Transform-tool will help - get the Pivot Point into place - call Coord-System tool and hit "Burn pivot point" - now adjust "Position" at the Polygon object.
PivotPoint.jpg
 
Last edited:

Cadlet

Member
Let´s see - there a more than one way to do it:
Quickest way to get objects center to XYZ=0 is to call Coord-System tool and hit "Center Pivot Point", then "Burn pivot point" and adjust at Polygon object "Position" to XYZ=0,0 - done.
Or if you want a specific point to be at YZX=0 like a the ground plane of a house for instance go in "Pivot-mode" - snapping to component at the Transform-tool will help - get the Pivot Point into place - call Coord-System tool and hit "Burn pivot point" - now adjust "Position" at the Polygon object.
I'm having problems keeping multiple primitives on the same floor when when exporting even though snapping is set to component (actually, I've tried surface and raster, too, of course). Here's an example.

I've got a coin-shaped tube. I've positioned it so that component snapping of the bottom flat side shows that all polygons of that surface meet the floor at y coordinate 0.0932. How can I make .0932 become y cordinate 0, and apply that coord system to the other primitives of the same plane in the scene so I can adjust their corresponding polygons' y coordinates to 0? The problem is that although all primitives of the scene appear to have snapped to the same floor, they have different floors when I export to .stl and bring them into the slicing program of a 3D printer.

I can work with them painstakingly at large magnification to make them compliant, but they don't appear to snap that way.

I suppose one workaround is to calculate half the height of any floor plane primitive and enter that as the y coordinate, but I wanted a more direct method.

Sorry if I missed that in the explanation you already provided. Thanks.
 

frank beckmann

Well-known member
You need to set the bottom of the coin as the pivot point:
Use snapping to component
enable Pivot mode and let transform gadget snap to the bottom mid point of the coin
call Tools->Coord System and hit "Burn Pivot Point" to make it permanent
Call the transform tool; you can now see where the bottom point is at the Y field
paste in "0.0932" at the Y entry field and you´re set.
 

Cadlet

Member
Anyway, apart from entering multiple numeric values, your first reply provides the fastest way to solve the problem. Thanks again.
 
Top