Bug reporting

#1
Bug reporting

Is there any official channel for reporting software bugs?

Using the latest stable release Cheetah3D (7.2.1)

I'm a newbie to the Cheetah software, but have found some strange issues around zooming & hot-keying.

My mouse is set to a three-button mouse in Preferences>Mouse, I'm using a three-button mouse (HP make).

These are the apparent listed usage commands for the mouse

Three button mouse:

ALT + LMB Drag:
Rotate camera around object.

ALT + MMB Drag:
Move camera.

ALT + RMB Drag:
Zoom camera.

ALT + Scrollwheel:
Zoom camera.

The only command I can get working with the mouse is MMB Drag - Rotate camera around the object, or Rotate the viewport around the Object whilst in perspective view.

I've tried hot-keying the command Zoom-in & Zoom-out and Zoom-Focus in preferences as a work around, but zoom-in, Zoom-focus as a hot-key only seems to work once or twice and then stop working. However, the zoom out seems to work all the time hot-keying as expected.

I could change the mouse, but was hoping that solution wasn't necessary.

Looking for some guidance on this issue.
 
#2
I had a similar issue and what I found was using my MacBook, I was actually resting my thumb to close to the track pad while my finger was on the option key. As a result, I could not zoom with the wheel. I could only rotate around with the wheel and pan with the middle mouse.

It drove me nuts until I figured this out. It was a problem I was having just with my MacBook and not with my iMac. I thought I was going crazy.

I am not sure if you are having the same issue, but something to consider.
 
#3
Thanks for mentioning the option key in your post! :icon_thumbup:

I noticed my keyboard is a windows keyboard. I'm using a mac mini with non-apple keyboard/mouse for convenience. :frown:

I grabbed an apple keyboard off my imac and tried it out.... pressing the option+mouse scroll now works :p
 
#4
Another bug I noticed today. When you have two separate meshes with solid colors... when you merge the mesh, the color assignment disappear on 1 of the meshes. Anyway else encounter this kind of problem before? If so, any workaround as its a bit of a pain having to reapply colors again.
 

Helmut

Active member
#6
* Merging since the current version should assign materials of merged objects to consecutive shade selections of the combined merged inject, #1 to #24.
* As Jeanny, I can not replicate your problem.
 
#7
Hi Jeanny, Helmut,

1 mesh had about 23 solid colors or more, the merging mesh didn’t need to have any. The mesh with solid colors had meshes that were separated in a few parts. A screen shot of model withthe issue is below. I also encountered it before on another model. Maybe others cheetah user haven’t encountered this problem, because I’m needing to do some unusual things to make animated models work for usdz. I need to create a single uv_map for multiple skeleton animations with all joints combined into a single skeleton. My animations are working as usdz... but its not the normal way to go about it. I don’t want to share this model at the moment as JAS. but when I get time, will try and recreate the issue on a simple model with 23 solid colors or more.
 

Attachments

Helmut

Active member
#8
* I can replicate the subsequent:
* box 1 is sectioned 3x3x3
* box 1 has 23 colours applied to its sections
* box 2 is plain
* a merge (in either direction) keeps the colours 1..16 but deletes the colours 17 onward.

* After some more tests on smaller boxes:
* It seems that any merge only takes 16 colours :eek:
* @ Frank B:
* Maybe pass this on to the Good Doctor.
 
#11
This is strange. I can´t find any version (gone back to v7beta13) where merging with more than 17 assignments ever worked and more than 23+1 default materials won´t work too.
So we didn´t do a great job in testing as it seems. :unsure:
@ash72: I don´t see in your halloween image more than 17 colours though.
24Selections.jpeg

Cheers
Frank
 
#12
Hi Frank,

Like I said, merging characters into a single mesh is why I unearthed this bug... which is probably not the norm. But I’m still surprised its never been discovered by someone else. The Halloween model had a few greens and blacks which were nearly the same shade. The image above is also the single uv color map I built from the solid colors... so they blended a bit. The usdz version of the model is available at www.fusionar.app
 

Helmut

Active member
#13
* Well, I guess it does not happen often that any model - when merged - ends up having >16 materials.
* I checked the Boolean addition method + collapse as a potential work around. This seems to end up with 8 materials and wildly reassigns those.

* Unfortunately, I have to perform some laborious testing of brewery products this afternoon and am prevented from continuing my diligent duties in the required state of sobriety :sick::mad::devilish:
 

Jeanny

Active member
#14
It’s a coincidence: I was having problems yesterday with Color Matts not holding to their selection number assignment. I was trying to make something with quite a few booleans and objects inside of objects (not merged though)

I was trying to get something done for Halloween. Hope to post the whole project soon.

Right now I can’t go into detail - I’m so exhausted.

Hope this might help somewhat.

My Best
Jeanny
 
#16
Thank you, I'm happy you enjoy them. I also want to send you my gratitude... as I benefited from the learning resources you made available on your website and here. Without contributions from others it would be a lot hard learning some of the more advanced aspects of using C3D!
 
Top