Aligned Particle Spline.js

tg_jp

Active member
#1
Aligned Particle Spline.js

Hello

it's a particle script, place it into ~/Library/Application Support/Cheetah3D/scripts/Particle folder.

each particle rotated along to spline path with absolute distance. you can make something like domino-effect objects easily with this script.

download: http://www.tres-graficos.jp/blog/files/article.php?id=70

update 20140329: 'offset' parameter added.



regards.

tg_jp, Hiroto.
 
Last edited:
#3
How to loop objects through path with offset

Hiroto, this script is great. I added just a few things to add an offset, so that I can animate the objects along the path. The question I have is, what's the best way to have each object cycle back to the front of the path when it gets to the end? If you run my version of the script, you'll see that the objects fly off the last path point into space. I'd like it to return to the beginning.
Any help is greatly appreciated.
Thanks for the script and in advance.

Here's my partially useful offset version:

Code:
[removed by crg because Hiroto came to the rescue as usual]

Hello

it's a particle script, ...

tg_jp, Hiroto.
 
Last edited:

tg_jp

Active member
#4
hi, thank you for your request.

The question I have is, what's the best way to have each object cycle back to the front of the path when it gets to the end? If you run my version of the script, you'll see that the objects fly off the last path point into space. I'd like it to return to the beginning.
Any help is greatly appreciated.
Thanks for the script and in advance.
I have just updated it with 'offset' parameter. I hope you like it. please update it.

http://www.tres-graficos.jp/blog/files/article.php?id=70



regards.

tg_jp, Hiroto.
 
#6
report

Hi Hiroto,

In CHeetah3D v7beta22 I get a javascript error message when using the aligned spline particles script.

The screenshot is of the 2011 version but the 2014 version shows the same error (line 78 ).

Correction: My fault, used wrong folder!
 

Attachments

Last edited:
#8
Frank, thanks for your feedback.
I tested further and found that I had misplaced the script in the spline folder instead of the particle folter :redface:

So everything is ok :smile:
 
Top