Mirror Copy.js

tg_jp

Active member
Mirror Copy.js

Hello,

this is Tool script for copying object symmetrically. for character bones.;)
this works for v4.0+.

please check sample movie.
sample movie (h.264 8.8Mb):http://homepage.mac.com/camelio/ch_movies/ch_20070324_mirrorCopySM.mov

UPDATED: now you can copy polygon objects.
UPDATED: fixed polygon object copying bug. 2008-06-06

download->http://www.tres-graficos.jp/blog/files/article.php?id=25

UPDATED: fixed bug for 5.0. 2009-10-14
UPDATED: fixed bug for 5.2. 2010-01-21

download for 5.x -> http://www.tres-graficos.jp/blog/files/article.php?id=51

tg_jp, Hiroto.
 
Last edited:

tg_jp

Active member
hi,

Heh -- I just *did* ask and was referred to this script. Does it mirror constraints?

yes. this script copy all tags ( Constraints, Handle ) with parameters.

but testing may not be enough. so if there is a bug after your testing, please let me know it.

regards.

tg_jp, Hiroto.
 

podperson

Well-known member
I can't currently use this script. I installed it and it doesn't shop up. I tried an older version I had lying around and had the same problem? Am I screwing up something or is there an incompatibility with 4.3.1?
 

frank beckmann

Well-known member
Mmmh - works just fine here.(Tiger/Cheetah4.3.1)
Are you sure storing it at: Harddisk/User/Username/Library/Application Support/Cheetah3D/scripts/Tool/ ?

Cheers
Frank
 

tg_jp

Active member
hi,

> podperson

thank you for trying this script. I checked it with Cheetah3D 4.3.1, it worked with my Mac. so, I don't know why it doesn't. any alert?

* doubleclick a file Mirror Copy.js_20070730.zip to extract it.
* place it ('Mirror Copy.js') into ~/Library/Application Support/Cheetah3D/scripts/Tool folder
* relaunch document and select 'Mirror Copy.js' from 'Tool -> Script -> Tool Script' menu.

please make sure that script file name is 'Mirror Copy.js'. '.js' extension is required for script file.

regards.

tg_jp, Hiroto.
 

cnitteberg

New member
I use leopard(10.5.1) and I had to put it in:
Harddisk/Applications/Cheetah3D/scripts/Tool/

where all de other scripts are.

If you doesn`t find it just search for one of the other scripts that come with Cheetah3D with spotlight!
 

tg_jp

Active member
update for bug fix

hello.

I updated this script. I fixed a bug that mirror copying of polygon objects caused error with version 4.6.

if you use it, please replace it.

regards

tg_jp, Hiroto
 

podperson

Well-known member
I'm having a lot of trouble with the copy/paste parameters function -- it produces twisted results. I don't think I had this problem before.

I modified the script to replace "L-" at the beginning of an object name with "R-" (vs. "..._copy" so "L-thigh" becomes "R-thigh") but as far as I can tell your code doesn't rely on names, so I think that the order of children in the copies has changed vs. v4.0 (the problem seems to occur if the hierarchy branches, but it sometimes occurs elsewhere).
 

tg_jp

Active member
hi,

thank you for reporting. but I cannot reproduce it, it occurs that problem with all mirror plane (x/y/z) or certain plane?
if it available, please post the file.

I already updated the script to fix parameter copy/paste bug, and add pivot copy/paste for v.5.0. if you not yet, please update it. ( few line added, so you can easily modified your customized one. I will add name conversion function for next update. ;) ).

http://www.tres-graficos.jp/blog/files/article.php?id=51

regards.

tg_jp, Hiroto.
 
Last edited:

podperson

Well-known member
I was using the latest version on the website as of two days ago. I'll see if I can dependably replicate it and post the file.
 

podperson

Well-known member
I think my file had some kind of internal corruption in it (the unique id issue again) because I ran into a bunch of problems while trying to move things around inside the hierarchy. So maybe the problem is just me.

I did come across this error though (note that the right hand has a gun in it while the left does not, which means the hierarchy is not perfectly symmetric).
 

Attachments

  • Screen shot 2009-12-08 at 10.30.20 AM.png
    Screen shot 2009-12-08 at 10.30.20 AM.png
    115.5 KB · Views: 548
Top