Keyframing Dynamics

#63
I´m in-between: 7.4.3/10.13.6 What I´m overlooking?
Bake simulation • shift+E->FBX7.5.0/Binary/everything checked except UV2 coords=no anim data
After baking the simulation you need to select the animated parts at frame 1 and record keys of their position and rotation (physics doesn't affect scale I think).
Then the same at frame 2 till the last frame.
__

Cheetah 7.4.3 ???
 
#64
Cheetah is still my fave of course, but if anyone is interested Marmoset Toolbag rendered this 720p 121 frame animation in just 5 minutes.
https://www.dropbox.com/s/56mg1z2laa2m7mu/rigidbody2b.mp4?dl=0

@Frank, hmmm, maybe it is the OS?? seems unlikely though... wait are we talking about export or import? Above, I mentioned that I was able to import miso's fbx into c3d. I haven't made my own yet...
--shift studio.

Edit. Tried to make the video more similar to Cheetah's by making the marterials similar and using oldtownpano.hdr. MT3 took 3 minutes to achieve similar quality rendering as C3D, which took 25mins.
see 'Edit 2'
look like cr@p viewed in dropbox website. Download looks like it should

Edit 2: tweaked some GI and shadow settings in MT3 (2mins render and encode)>> https://www.dropbox.com/s/6kj85ejvd1ychte/rigidbody2f.mp4?dl=0
 
Last edited:
#66
I'm back onto the soft body examples and trying to get those examples working as well. Soft body anchor seems like the easiest example to get working first as it doesn't have a wind effector... just a couple of anchors.

It seems that when you check keyframes recorded on the plane mesh in the example -> soft body anchor.jas... key-framing for points, smooth, smooth angle get recorded.... is this correct? If so, why isn't that exporting to FBX or DAE correctly? If you look in blender after the fbx export. The balll falls correctly. However the plane is stuck on the last frame. If you look in the NLA track, its got keyframe data points against the plane... so maybe this is a bug of some sort with the export?
 
#68
Yeah I hope Martin checks this thread and lets us know. glTF doesn't export any points animation data ( i read in the glTF thread that Martin was planning to add morph targets?). I just checked in Blender with the soft body anchor.jas and it only has the ball animation data. However, with the FBX export, animation data is showing up on the plane in Blender. However when you play the animation, the ball animates but the plane is stuck on one frame, looks like maybe the last. The telling point is the plane is crinkled. Which means at least one frame of the plane has been key-framed correctly in respect to the vertex points. So I'm guessing its a bug why all the frames are not playing...... and because no one has utilised these dynamic baking features up until recently in C3D.... its gone undetected until now?
 
#69
With the DAE export to Blender 2.79. The animation data on the plane is also showing... the plane has a few frames which skip & change as if it's trying to work. Again I'm guessing it may be a bug.
 
Top